ラズパイ3 model B でpuppeteerを動かすまで

いったんは諦めたのですが、しばらく放置してる間に情報がでて揃い始めてたっぽいのでせっかく買ったので有効利用したいと思います。

ヘッドレスchromeは64bit OSでないと動かない?

そう思って以下の記事の内容を実行しました。結論から言うと無駄だったかも。
ubuntuが好きなので、ただのubuntu mate でよかった可能性。

つまづきポイントは、viの使い方がわかんないところです。
32bit OSの立ち上げがうまくいったあとに、windowsでconfig.txtに書き込んじゃえばいいです。
デスクトップはいらないかもしれないけれど kubuntuとやらを入れてみました。

Nodeのインストール

デスクトップが立ち上がったら、何は無くともnodeのインストールです

Ubuntuに最新のNode.jsを難なくインストールする 
https://qiita.com/seibe/items/36cef7df85fe2cefa3ea

上記の記事を参考にして、npmを使えるようにします。

やっぱりpuppeteerが動かない・・・・

結局動かなかったんですよ

こちらの記事を参考にしました。

これでいけました。
記事内ではバージョンを下げてますが、特に下げずに動いた上API不具合とやらもありませんでした。

プログラムを動かす

GCEで動かしてたプログラムが動かなくなっちゃったのでラズパイに移行しました。
ちょっと身近になったので、ほかにもプログラムを作ってみようと思います。