qTranslate‑Xでエラーがでてヤバイ!その解決法!

こんなエラー出てきませんでした?

Warning: Parameter 2 to qtranxf_postsFilter() expected to be a reference, value given in /***********/wp-includes/class-wp-hook.php on line 286 Warning: Parameter 2 to qtranxf_postsFilter() expected to be a reference, value given in /***********/wp-includes/class-wp-hook.php on line 286

TOPページにアクセスしたら出てました。
ヤバイですね。

qTranslate‑Xは開発が2年ほど前から止まっている。

そういうことです。
開発が止まっているため、ついにバージョンについていけなくなったのです。
qTranslate‑X を使い続けるのは諦めた方がいいです

有志で開発しているqTranslate‑XTに乗り換えよう!

qTranslate‑X は git-hubというサイトでソースが公開されています。
非常に有用なプロジェクトであるため、開発をやめてしまった開発者の代わりに「最新の環境で引き続き動く」ということを目指しているプロジェクトがあります。

それがこちら
https://github.com/qtranslate/qtranslate-xt

プロジェクトをzipファイルとしてダウンロードできますので、そのファイルを新規プラグインとしてアップロードしてあげるとqTranslate‑Xのかわりとして動きそうです。

非常にありがたいですね。
今回自分は、制作途中のサイトであったので、エラーについてはそんなに問題にはなりませんでした。が、今後問題が出ることもあると思うので早めに乗り換えたいですね。
まだ自分もこのプラグインに差し替えたばかりなので何か気づいたらこちらに追記していきたいと思います。